Главное окно программы

После входа в программу (ввода логина и пароля), начинается процедура автоматического поиска сетевых устройств в составе локальной сети.

Все найденные сетевые устройства будут идентифицированы и внесены в список найденных устройств в окне "Устройства". Вслед за этим, на экране компьютера открывается главное окно программы.

Функционально главное окно состоит из двух частей: главной панели управления (вертикальная панель в правой части экрана)
и набора окон отображения камер.

Главная панель управления предназначена для вызова (открытия) окон позволяющих настраивать параметры
функционирования программы и управлять режимами работы комплекса в целом:
«Свернуть приложение», «Окончить работу», «Перезагрузить компьютер», «Выключить компьютер».

Внимание! При нажатии на кнопку «Свернуть приложение», отображение всех элементов программы исчезнет с экрана компьютера, но приложение по-прежнему будет фун [image] кционировать и в трее появится стилизованная под камеру иконка, соответствующая приложению. Нажатие на эту иконку, позволяет вернуться к основному режиму отображения окон программы. Этот режим рекомендован для проведения кратковременных операций на компьютере (например, проверки писем электронной почты) и не может быть использован в качестве основного режима.

Кнопка с изображением стрелки, расположенная в правом нижнем углу экрана, позволяет свернуть главную панель управления.
После сворачивания, ПОД главной панелью располагаются:

панель активности камер и набор закладок для быстрого выбора шаблона отображения камер (если выбрана опция «Отображать шаблоны во вкладках» в окне «Шаблоны»). Иконки камер на панели активности камер, связаны непосредственным образом с окнами отображения камер – каждому окну
подключенной камеры, соответствует иконка на панели активности. Иконки камер отображают цветом состояние соответствующей камеры: зеленый – камера активна и полностью функционирует, серый – камера не активна, красный – запись с камеры не производится, желтый – «промаргивает» в моменты записи камеры, при детектировании движения.

Расположение каждого конкретного окна камеры на главном экране, можно изменить, используя функцию Drag&Drop: произвести нажатие и отпускание правой клавиши мыши (правый клик) на иконке камеры, соответствующей перемещаемому окну, на панели активности камер. Курсор мыши при этом изменится типовой курсор функции Drag&Drop - прямоугольник со стрелкой. Подвести этот изменившийся курсор к желаемому месту расположения окна камеры, в рядах окон отображения других камер. Нажать и отпустить любую клавишу мыши, при этом перемещаемое окно, установится в новое положение в рядах окон отображения других камер. Курсор вернется к своему изначальному виду и иконка соответствующая перемещаемому окну, также изменит свое местоположение на панели активности камер. Строго говоря, использование функции Drag&Drop, позволяет поменять местами две камеры – выбранную и ту, на чье место она переместилась. Эта функция позволяет размесить окна камер на экране, оптимальным для просмотра образом .

При необходимости, панель активности камер и закладки шаблонов можно свернуть. Для этого, необходимо нажать на кнопку сворачивания (кнопка с изображением камеры со стрелкой), в верхней части панели активности камер. После сворачивания панели активности и закладок, кнопка сворачивания переместиться в правый нижний угол экрана. Повторное нажатие на кнопку сворачивания, вернет отображение панели активности и закладок шаблонов.

Для удобства пользования, в верхней части главной панели управления, расположена кнопка сворачивания всех окон отображения камер. При нажатии на эту кнопку, все окна камер (включая и не активные) не будут отображаться на экране. Прием, обработка и
сохранение медиа контента камер, будет производиться по-прежнему. Повторное нажатие на эту кнопку вернет отображение окон камер.

Для вызова наиболее часто используемых операций, в окне каждой камеры можно вызвать контекстное меню. Вызов меню активируется нажатием правой кнопки мыши, в окне камеры.

Для камер обеспечивающих поддержку функций PTZ (Pan&Tile&Zoom) при выборе окна камеры, на главной панели управления появляется дополнительная панель управления PTZ ,
в которой можно:

- управлять перемещением камеры в различных направлениях;
- менять скорость перемещения, согласно опциям производителя камеры;
- производить оптическое зумирование (ЗУМ) объекта (приближать/удалять);
- менять фокусировку (ФОКУС) и диафрагму (ИРИС) оптической системы камеры.

Комплекс «Провин» в своем составе содержит встроенный высокоскоростной web-браузер, на основе "движка" Google Chrome, позволяющий работать в режиме реального времени с web-сервисами IP-устройств (IP-камерами и видеорегистраторами). Таким образом, все встроенное программное обеспечение любого подключенного IP-устройства, становиться неразрывной частью программно-аппаратного комплекса «Провин».

Для создания сложных алгоритмов управления PTZ необходимо нажать на кнопку «Аппаратные настройки» в окне «Устройства», для выбранной камеры с PTZ . Далее, после «входа в устройство», произвести любые необходимые изменения (например: создать контрольные точки для перемещения камеры, включить патрулирование и т.п.). При закрытии окна встроенного браузера, все произведенные изменения, будут автоматически отражены в окнах отображения и в архивных записях устройства.


Окно "Информация"

На верхней панели окна «Информация» отображается текущая дата и время, кнопка отображения календаря. Ниже, в левой части, расположена информационная панель, в которой отображается вся необходимая [image] информация о системе: папка текущего архива, краткая информация о подключенных камерах – их количество, количество камер с ошибками (для сервера), перечень доступных архивных дисков, параметры сети – локальная подсеть (для сервера) или IP-адрес (для клиента), гистограммы динамической загрузки памяти и процессоров (усреднённое значение для всех процессоров компьютера).

При нажатии соответствующих кнопок на правой панели окна «Информация», в отдельных окнах отображаются:
сведения о программе (компания разработчика, версия программы), параметры лицензии (для сервера), сведения о компьютере и текущих процессах в памяти компьютера. Кнопка «Отчет об ошибке» открывает информационное окно, с описанием возможных действий пользователя, в случае возникновения ошибки.

Выше кнопочной панели расположен регулятор уровня громкости акустической системы, позволяющий изменять громкость непосредственно из приложения.


Окно "Шаблоны"

В этом окне можно выбрать, изменить, удалить и создать новый(-е) шаблон(-ы) для отображения подключенных устройств, в главном окне приложения. Интерфейс главного окна программы позволяет отобразить до 64 подключенных устройств, в виде отдельных окон.
Для выбора шаблона отображения используется селектор «Выбор шаблона». При нажатии кнопки «Шаблон по умолчанию», выбранный шаблон можно сделать текущим шаблоном, который сразу изменит вид отображения главного окна и в дальнейшем, будет выбирать автоматически, при каждом старте приложения.

Для быстрой смены шаблонов отображения устройств, необходимо активировать (выбрать) «Отображать шаблоны во вкладках», при этом, в правой части главного окна приложения, появятся закладки, отображающие все шаблоны текущего пользователя. При выборе любой из вкладок шаблонов, изменится вид отображения главного окна и в дальнейшем, приложение будет выбирать выбранную вкладку автоматически, при каждом старте приложения.

В приложении, создан набор предустановленных шаблонов. Все предустановленные шаблоны можно оставить без изменения, модифицировать или удалить.
Для удаления конкретного шаблона, его необходимо выбрать селектором «Выбор шаблона», а затем нажать кнопку «Удалить шаблон».

Внимание! Удаление шаблона – операция необратимая: шаблон будет удален из списка шаблонов и для повторного использования, его будет необходимо создать заново, согласно нижеприведенного описания создания и сохранения шаблона.

При выборе (и при создании) шаблона, в нижней части экрана (над кнопкой «Сохранить как..»), отображается панель «Всего устройств отображения» с указанием точного количества окон отображения подключенных устройств, для конкретного шаблона.

Для создания и сохранения нового шаблона(-ов) используется панель эскиза главного окна. Панель расположена под селекторами «Выбор шаблона» и «Отображать шаблоны во вкладках».
Количество окон отображения на главном окне создаваемого шаблона регулируется горизонтальными и вертикальными регуляторами у панели эскиза. Панель эскиза позволяет создавать и отображать макет главного окна, с максимальным количеством до 64 подключенных устройств – 8х8 окон отображения.
Кроме того, панель эскиза позволяет создавать шаблоны, содержащие одно увеличенное окно отображения: размерами 2х2 или 4х4, от стандартного размера обычного окна отображения.
Выбор размера увеличенного (2х2 или 4х4) окна, производится селекторами под надписью «+ Большое окно».
Следует отметить, что программа автоматически определяет возможность использования увеличенного окна, для конкретного создаваемого шаблона.

Сохранить новый, созданный шаблон, можно при нажатии на кнопку «Сохранить», предварительно вписав название нового шаблона в редактируемое поле «Сохранить как..».
Название нового шаблона может быть произвольным и может содержать цифры и буквы в любом регистре.
Внимание! Следите за тем, чтобы имена создаваемых шаблонов были уникальными, во избежание перезаписи уже существующего шаблона.

Нажатие на кнопку «ОК» сохраняет все произведенные операции и закрывает окно «Шаблоны».


Окно "Устройства"

Это основное окно сервера комплекса «Провин», используемое для поиска, добавления, подключения, отключения и удаления IP устройств (камер и каналов видеорегистраторов) в составе локальной сети.

В верхней части окна программа отображает найденные сетевые устройства, индицирует их IP и MAC адреса, тип, модель и производителя устройства. Ниже располагается панель отображающая общее количество найденных устройств, количество подключенных и устройств с ошибками (в работе которых программа зафиксировала ошибки: например устройство прекратило передачу видеопотока для записи). Сканирование устройств в состве локальной сети, проводимое при входе в программу, автоматически определяет IP, MAC адреса, типы, модели, производителей устройств, наличие и состав PTZ для поворотных камер и наличие поддержки сервисов ONVIF в устройствах. Повторное сканирование устройств в составе локальной сети, можно осуществить нажатием на кнопку «Поиск устройств».

При выборе любого устройства из списка найденных, программа автоматически заполняет поля «Имя» и «IP адрес» в группе «Настройки IP-устройства». Если модель устройства была определена автоматически, в качестве имени устройства "по умолчанию" используется наименование модели.
При необходимости, имя устройство может быть изменено на любое другое, например: «Камера у подъезда №1». Количество символов в имени камеры – не более 64 символов.

Процесс подключения IP-устройства (камеры или канала видеорегистратора) двухэтапный.
На первом этапе, при нажатии на кнопку «Добавить» устройство добавляется в список обработки потоков от IP- устройств. При этом, в нижней части формы, в разделе «Информация о подключенном устройстве» будет индицироваться информация об устройстве. Следует заметить, что заполнение полей «Логин», «Пароль», ДО нажатия на кнопку «Добавить», не является строго обязательным, эта информация может быть введена позже, но не позднее нажатия на кнопку «Подключить» .
Далее необходимо:

  • Выбрать тип подключения – по протоколу ONVIF или без него (описание ONVIF можно посмотреть на сайте сообщества ONVIF www.onvif.org). Наличие у устройства поддержки ONVIF, программой определяется автоматически, на стадии идентификации сетевых устройств в составе локальной сети.
  • Селектором «Режим записи» выбрать необходимый режим записи («По движению» или «Постоянная») или при необходимости отключить запись информации устройства в архив. По умолчанию установлен режим записи «По движению», реализующий запись в архив, по встроенному детектору движения. Этот режим, в большинстве случаев, является оптимальным, из соображений экономии свободного места на архивных дисках;
  • Селектором «Видеопоток» выбрать тип обрабатываемого потока от устройства – «Субпоток» или «Основной поток». По умолчанию в качестве видеопотока установлен «Субпоток», т.к. это позволяет значительно экономить ресурсы компьютера (загрузку памяти и процессора, дисковых устройств);
  • Для камер со встроенным управлением функциями PTZ (Pan&Tile&Zoom), автоматически активируется параметр «Поддержка PTZ»;
  • Для камер имеющих встроенный аудиоканал, при необходимости обработки аудио информации (прием, обработка, проигрывание и сохранение), включить «Аудио канал»;

После добавления устройства, с заполненными необходимыми, параметрами необходимо:

  • ввести «Логин» и «Пароль» для подключения к устройству (эти параметры должны быть известны на момент подключения: обычно логин и пароль «по умолчанию», можно найти в документации производителя устройства, поставляющейся вместе с устройством). Логин и пароль могут содержать до 32 символов каждый;
  • Нажать на кнопку «Подключить». При этом, в главном окне программы и на окне отображения устройства, расположенного непосредственно на форме, отобразиться видео от подключенного устройства. Скорость входящих потоков видео- и аудио (при его наличии) будет отображена в верхней части окна видео.
  • Режим отображения видео на главном окне программы можно изменить селектором «Отображение». Поддерживаются следующие режимы отображения:
    - «Стретч» - режим «растягиващий» входящее видео по размеру окна отображения;
    - «Пропорция» - режим отображения с сохранением пропорций (высота-ширина) входящего видео;
    - «С обрезкой» - режим отображения, в котором все «не входящие» в размер окна, части видео, обрезаются (не отображаются).
    Изменять режим отображения, для любого из подключенных устройства, можно в любой момент времени. В качестве, режима отображения «по умолчанию» выбирается режим «Стретч», позволяющий отображать полноразмерное видео, в окне любого размера.

На этом этап добавления и подключения IP устройства можно считать завершенным.

Следует добавить, что для совместимости с любыми типами/моделями IP камер и видеорегистраторов, в окне настройки устройств имеются дополнительные поля:

«Порт*» - позволяет ввести любой номер порта для обработки приема видео/аудио в составе RTSP или HTTP потока, отличный от стандартного (554 или 80);
«URL*» - позволяет «вручную» ввести строку RTSP или HTTP запроса для приема видео/аудио от устройства. Максимальное количество символов в строке URL : 128 .

Комплекс «Провин» в своем составе содержит встроенный высокоскоростной web-браузер на основе "движка" Google Chrome, позволяющий работать в режиме реального времени с web-сервисами IP-устройств (IP-камерами и видеорегистраторами).Таким образом, все встроенное программное обеспечение любого подключенного IP-устройства, становиться неразрывной частью программно-аппаратного комплекса «Провин».

Для изменения любых аппаратно-программных настроек, подключенного IP-устройства, необходимо нажать на кнопку «Аппаратные настройки».
Далее, после «входа в устройство», произвести необходимые изменения (например: изменить разрешение (Resolution), произвести коррекцию яркости (Brightness) и контрастности (Contrast) и т.п.). При закрытии окна браузера, все произведенные изменения, будут автоматически отражены в окнах отображения и в архивных записях устройства.

Для временного отключения устройства, необходимо нажать кнопку «Отключить». При этом, все входящие потоки от устройств обрабатываться (отображаться и сохраняться) не будут, несмотря на то, что окно отображения устройства на главном экране будет по-прежнему зарезервировано под это устройство. Повторное подключение, можно осуществить нажатием на кнопку «Подключить».

Для полного удаления IP-устройства из цикла обработки входящих видео-аудио потоков, необходимо нажать кнопку «Удалить». При этом, окно отображения устройства на главном экране, и все его параметры настройки, будут также удалены. Однако, все архивные записи, произведенные этим устройством, после удаления останутся неизменными.
Для повторного подключения удаленного устройства, необходимо пройти полный цикл добавления-подключения устройства, описанный выше.

Подключение каналов видеорегистратора аналогично вышеописанному подключению камер, но есть небольшие отличия:

- при выборе видеорегистратора в списке найденных устройств, над полем «URL», появляется панель «Видеорегистратор»с двумя дополнительными поля «Каналов» и «Выбрать канал». По-умолчанию поле «Каналов» имеет значение 64,
что соответствует максимальному количеству каналов поддерживающимся программой. Это значение, необходимо изменить на реальное количество каналов регистратора и выбрать текущий канал в поле выбора «Выбрать канал». Дальнейшие действия, аналогичны подключению камеры.
- для подключения следующего канала, необходимо повторно выбрать текущий видеорегистратор из списка найденных устройств (при этом будет индицироваться последний подключенный канал), заполнить наименование нового канала («Имя») и номер канала («Выбрать канал»), затем нажать «Добавить» и после добавления канала, нажать «Подключить».
- все остальные каналы регистратора, подключаются таким же образом. Следует отметить, что комплекс «Провин» поддерживает и не последовательное подключение каналов видеорегистратора - все каналы могут подключаться "вперемежку" с камерами.

Отключение и удаление каналов видеорегистраторов производится согласно вышеописанному, как и у камер.


Окно "Сеть"

Комплекс «Провин» работает на сервере в составе локальной сети, включающей в себя различного рода IP-устройства (камеры, видеорегистраторы), активное или пассивное сетевое оборудование (роутеры, свичи, хабы) и компьютеры. В целях расширения масштаба сети и поддержки большого количества камер (свыше 4000 камер ), в составе локальной сети могут одновременно функционировать несколько десятков (до 64) серверов «Провин». Доступ к каждому из серверов, с возможностью просмотра камер и архивов, осуществляется с помощью клиентской программы комплекса «Провин». Кроме того, каждый из серверов комплекса, также может выступать в роли клиента любого из серверов, входящих в состав локальной или распределенной сети.
Окно «Сеть» позволяет осуществить настройки доступа к сервисам сервера и производить подключение к другим серверам.

В верхней части окна «Сеть» отображаются все клиентские сетевые подлючения к серверу, основные события протокола обмена клиент-сервер (только для серверов). Кроме того, отображаются и основые сетевые характеристики сервера: web-адрес (адрес в сети Интернет ,при наличии подключения), lan-адрес (адрес в составе локальной сети), маска и шлюз подсети сервера.
Для обмена медиа контентом и приема-передачи служебной информации, комплекс «Провин» использует многопортовые потоковые сетевые подключения. Начальное (базовое) значение портового пула каналов сервера, можно изменить, вводом нового значения в «Порт связи» и нажатием на кнопку «Изменить». В сетях распределенного доступа, использующих активное сетевое оборудование (маршрутизаторы), при необходимости можно открыть необходимое количество портов доступа к каналам сервера, исходя из соотношения: один канал = один порт сервера.

Добавление параметров серверов для связи (IP-адрес, логин, пароль, порт связи) производится в разделе «Добавить сервер» в нижней части формы. Все введенные параметры серверов сохраняются автоматически и в дальнейшем могут быть использованы для установления соединений.
Удаление сервера из списка серверов, производится нажатием на кнопку «Удалить сервер».
После ввода параметров серверов и добавления их в список (кнопка «Добавить сервер»), можно произвести подключение, к выбранному из списка серверу, путем нажатия на кнопку «Подключить сервер». При этом, все доступные камеры удаленного сервера, отобразятся на главном экране программы.

Действия в окне любой из камер подключенного сервера, ничем не отличаются, от действий с «обычными» подключенными камерами:
- при необходимости, можно сделать скриншот с сохранением в папке скриншотов, путем выбора пункта меню «Сделать скриншот», при нажатии правой клавиши мыши в окне отображаемой камеры;
- двойное нажатие левой клавиши мыши, в окне камеры, вызовет открытие большого полноразмерного окна камеры;
- вращением колесика мыши производится цифровое зумирование видео;
- просмотр архива камеры, подключенного сервера, производится путем выбора пункта меню «Операции с архивом», при нажатии правой клавиши мыши в окне отображаемой камеры;
- скрыть или повторно отобразить камеру, можно путем выбора соответствующего пункта меню,
при нажатии правой клавиши мыши в окне отображаемой камеры.

По окончанию работы с удаленным сервером, необходимо произвести отключение от выбранного сервера, нажатием на кнопку «Отключить сервер».
При окончании работы сервера, перезагрузки или отключении компьютера, программа автоматически завершит все активные подключения.


Окно "Журнал"

Все действия программы фиксируются в виде отдельных событий в LOG файлах программы и сохраняются в папке REPORTS директория установки комплекса.

В окне «Журнал» события отображаются в режиме реального времени, в момент их возникновения. Для удобства выбора при просмотре, в правой части экрана расположен набор фильтров, для выборки и сортировки событий.

При выборе фильтров событий из набора фильтров («Выбор фильтра»), события системы отображаются в журнале, с учетом времени их возникновения.

По умолчанию, в журнале отображаются события на текущую дату и в наборе фильтров выбраны всего две позиции «Запуск программы» и «Вход пользователя»

Для просмотра событий на любую дату используется селектор «Журнал на дату».

При долговременном использовании, РЕКОМЕНДУЕТСЯ производить периодическую очистку логов событий (файлы типа [DD-MM-YYYY].log, например: [01-07-2016].log), в папке REPORTS (не реже 1 раза в год).


Операции с архивом

В окне "Операции с архивом камер" можно настроить параметры и расположение архива записей камер на компьютере с установленным комплексом «Провин». При первом старте, программа автоматически проверяет логические диски компьютера, для определения архивного диска «по умолчанию». Чаще всего, это диск директория установки комплекса (обычно диск «C»). Любой из выбранных логических дисков, использующийся в качестве архивного диска должен обладать рядом требований, а именно:

- на момент выбора иметь «свободным » не менее 10 Гб;
- не содержать сбойные сектора для записи;
- иметь высокую скорость чтения-записи (желательно).

Для хранения архива записей на выбранном логическом диске программа автоматически создает папку архива <Диск>:/PRV-ARCHIVE (например: “D:/PRV-ARCHIVE” ). Все записи от камер, хранимые в архиве, можно подразделить на 3 типа:
- записи видеоинформации в формате mjpg;
- записи аудиоинформации в формате mp3;
- системные файлы и папки, использующиеся для обработки архивной информации.

Любые записи видео- и аудио- информации сохраненные в архиве, в дальнейшем могут быть проиграны любым медиа плеером, поддерживающим вышеперечисленные форматы хранения мультимедиа информации. Для удобства использования, комплекс «Провин», использует широко известный медиа плеер «Daum PotPlayer» ( http://potplayer.daum.net/).

Автоматически выбранный программой при первом старте, архивный диск может быть смен на любой другой (или на несколько любых) логический диск компьютера, по желанию администратора комплекса.
Таким образом, для хранения архивов записей может быть использовано ЛЮБОЕ количество архивных (логических) дисков, что позволяет значительно расширить возможности хранения больших архивов информации.

Выбор и смена текущего архивного диска производится селектором «Список архивных дисков».

Добавление нового архивного диска производится кнопкой «Добавить диск в список», предварительно осуществив выбор необходимого диска, из селектора всех доступных дисков компьютера, расположенного рядом с копкой.

Удаление архивного диска, выбранного селектором «Список архивных дисков», можно произвести, нажав на кнопку «Удалить диск из списка».

Внимание! При нажатии на кнопку «Удалить диск из списка» и выбранном пункте «С очисткой архива», ВСЕ архивные записи на выбранном архивном диске будут УДАЛЕНЫ.

Как уже упоминалось ранее, с целью увеличения емкости архива, в системе может быть использовано любое доступное количество логических дисков.
При наличии в списке архивных дисков нескольких логических дисков, комплекс «Провин» реализует следующий алгоритм записи и хранения медиа информации:

- если выбран пункт «Автоматическая смена архива»: при заполнении архивного диска (минимально допустимое значение объема свободного места – 2Гб), производится автоматический переход на следующий в списке архивный диск, и так циклически. При полном заполнении всех архивных дисков (на каждом менее 2Гб), на текущем архивном диске активируется автоматическая процедура очистки архивного диска – системой «затираются» наиболее «старые» архивные записи (записи от камер в течение 1 суток). Этот процесс также является циклическим, с переходом по всем архивным дискам.
- если не выбран пункт «Автоматическая смена архива» : алгоритм записи и хранения аналогичен вышеописанному, за исключением циклического перехода по списку архивных дисков. При этом запись, хранение и стирание информации происходит ТОЛЬКО на текущем архивном диске.

Помимо настройки архивных дисков, в этом окне можно также вызвать просмотр архив камер (с использованием встроенного архивного плеера). Для этого, из списка камер, расположенных в правой части формы, выберите необходимые камеры и нажмите кнопку «Показать». При этом, поверх окон отображения камер на главном экране программы, откроются вспомогательные окна выбора даты и времени архивных записей, для каждой конкретной камеры. В каждом из этих окон, используя встроенный календарь и время показа, можно, при нажатии кнопки «Показать» отобразить архивные записи камеры, для выбранного временного диапазона.

Селекторы «Время» позволяют выбирать времена записей в заданном интервале (от – до). Формат времени в каждом селекторе: <ЧЧ:ММ:СС>, где ЧЧ-часы, ММ-минуты, СС-секунды (например: 15:49:18 – 15 часов 49 минут 18 секунд).

Ежемесячный встроенный календарь отображает наличие записей (дата выделяется «жирным» шрифтом) конкретной камеры на текущую дату. При выборе любой даты, в селекторе «Время» отображается временной интервал (от-до) сохраненных записей (для дат с отсутствующими записями интервал отображается как 0:00:00 – 0:00:00). При выборе даты и временного интервала записей камеры и при нажатии кнопки «Показать», поверх окна выбора, откроется окно медиа плеера с автоматическим показом архивных записей.

Дальнейшее управление просмотром выбранных архивных записей
осуществляется непосредственно встроенным медиа плеером, использующих всю полноту управления практически любым медиа контентом. Мы не будем приводить полный список возможностей Daum Potplayer - они достаточно детально описаны на сайтах производителя (www.potplayer.ru и http://potplayer.daum.net/?lang=ru ), к тому же программа имеет простое и понятное меню управления. Приведем наиболее часто используемые «быстрые кнопки» управления просмотром в плеере:

Переход на следующий кадр - <F>

Переход на предыдущий кадр - <D>

Обычная скорость - <Z>

Уменьшить скорость - <X>

Увеличить скорость - <C>

Переход на 5 сек. назад - <←>

Переход на 5 сек. вперёд - <→>

Переход на 30 сек. назад - <Ctrl+←>

Переход на 30 сек. вперёд - <Ctrl-→>

Все остальные клавиши управления и режимы работы плеера, легко получить при нажатии на надпись «PotPlayer» в левом верхнем углу окна плеера.

Отображение архивной информации для конкретной камеры также легко получить и из контекстного меню, вызываемого на главном экране отображения камер, при нажатии правой кнопки мыши в окне выбранной камеры.

Первый пункт меню – «Операции с архивом» вызывает окно выбора даты и времени просмотра архивных записей выбранной камеры.

Все дальнейшие действия с окном выбора временных параметров и просмотром в записей плеере, аналогичны описанным выше.


Настройка сиcтемы

В этом окне можно произвести основные настройки программы:
- добавить или удалить пользователей программы;
- выбрать режим работы для аудио и видео устройств компьютера;
- выбрать и произвести изменение настроек встроенного плеера;
- сохранить или восстановить конфигурацию сервера;
- изменить параметры входа в систему.

Комплекс «Провин» поддерживает многопользовательскую работу для двух категорий пользователей: обладающих «Правами администратора» и без предоставленных прав на администрирование системы. Пользователи с правами администратора, могут производить любого рода изменения в настройках программы и вызывать любые функциональные окна, в отличие от пользователей без прав администратора.

При первом старте программа автоматически создает пользователя по умолчанию – «Администратор» без установленного пароля, с правами администратора системы. Предполагается, что в дальнейшем пользователь по умолчанию будет изменен: по крайней мере, будет установлен пароль на вход в систему. Использование комплекса без установленного входного пароля НЕ РЕКОМЕНДУЕТСЯ: во-первых это противоречит требованиям безопасности системы видеонаблюдения, во-вторых не позволит клиентским приложениям иметь доступ к серверу.
Кроме того, следует с осторожностью обращать с опцией «Автоматический вход»: при ее активации (выборе), вход в программу при запуске, будет происходить без запроса логина и пароля, с параметрами текущего пользователя. Этот режим удобен для автозапуска программы на компьютере, доступ посторонних к которому, гарантировано ограничен.

Для добавления нового пользователя необходимо нажать кнопку «Новый пользователь» и в открывшейся форме ввода ввести «Логин», «Пароль» и «Права администратора».

Для смены пользователя, необходимо выбрать пользователя из списка селектора «Пользователи» и в открывшемся окне подтвердить операцию смены.

Для удаления пользователя, заранее выбранного селектором «Пользователи», необходимо нажать кнопку «Удалить пользователя» и в открывшемся окне подтвердить удаление .

Для смены пароля текущего пользователя, необходимо нажать кнопку «Изменить пароль» и в открывшейся в форме ввести новый пароль пользователя.

Все вышеописанные операции по изменениям в списке Пользователей системы, доступны только пользователям с правами Администратора.

Группа настроек Аудио-Видео позволяет выбрать режим работы для аудио и видео устройств компьютера, настроить медиа плеер системы и включить/отключить анимированную заставку программы при старте программы (расположенную над формой ввода логина и пароля при старте программы).

Наиболее часто используемый параметр этой группы «Ускорение видео (HWA)», позволяет изменить режим рендеринга окон отображения видео от камер. Поддерживаются следующие режимы (они едины для всех окон видео): DirectX (режим быстрой графики и видео) , OpenGl (самый быстрый режим графики и видео), Software (режим обработки графики и видео, использующий оперативную память компьютера), Auto (программа сама выберет оптимальный режим рендеринга).
Следующие два пункта этой группы позволяют выбрать устройства ввода-вывода компьютера.
А пункт «Архивный плеер» позволяет выбрать и настроить встроенный медиа плеер, предназначенный для просмотра и прослушивания сохраненной информации от камер в архиве.
По умолчанию плеер настроен оптимальным образом, подходящим для большинства задач по отображению медиа контента. В текущей версии комплекса «Провин» используется мощный мультимедийный плеер Daum Potplayer. Полный спектр его возможностей описан на сайтах производителя (http://potplayer.ru/ и http://potplayer.daum.net/?lang=ru ).

Группа настроек «Конфигурация сервера» позволяет сохранить и при необходимости восстановить файлы конфигурации сервера, а при выбранной опции «Автосохранение» сохраняет информацию автоматически, при любых изменениях конфигурации.

Скриншоты с любых выбранных камер, произведенные в режиме реального времени из контекстного меню, вызываемого на главном экране отображения камер (при нажатии правой кнопки мыши в окне выбранной камеры и выборе пункта «Сделать скриншот»), хранятся папке хранения скриншотов, заданной в поле редактирования пути «Хранить скриншоты в..». Сменить папку хранения скриншотов можно при нажатии на кнопку с изображением папки, рядом с полем редактирования.

Комплекс «Провин» поддерживает два режима обновления программы, в рамках приобретенной лицензии: обновление в виде установочных файлов (обычно это установщики различных версий программы) и в виде специальных файлов обновлений, которые предоставляются для скачивания пользователям, службой поддержки компании «Провин» ( www.provin.pro ).
Запуск файла обновлений (если таковой был предоставлен для скачивания) производится при нажатии на кнопку «Установить обновление». Все установленные обновления отображаются в окне, открывающимся при нажатии на кнопку «Журнал обновлений». Информация о произведенных обновлениях, хранится в файле update.log папки REPORTS, директория установки комплекса.


Системные требования

Программно-аппаратный комплекс «Провин», предназначен для регистрации (получения, хранения и обработки) видео- аудио- информационных потоков от проводных и беспроводных сетевых устройств: IP камер и видеорегистраторов.

Для нормального функционирования комплекса, компьютер должен удовлетворять следующим требованиям:

Минимальные и общие требования:

  • Более 10 ГБ свободного места на жестком диске;
  • Операционная система Microsoft® XP SP3 и выше;
  • Желательно подключение к Интернет, для активации и обновления программ.

Аппаратные требования к компьютерам, на которых установлены операционные системы для рабочих станций:

Microsoft Windows XP SP3/Vista/7/8.1/10 x32/64 :

  • процессор Intel Pentium 2 ГГц и выше (или совместимый аналог);
  • 2Гб свободной оперативной памяти (и более).

Аппаратные требования к компьютерам, на которых установлены операционные системы для файловых серверов:

Microsoft Windows Small Business Server 2008 Standard x64 Edition, Microsoft Windows Small Business Server 2011 Essentials / Standard x64 Edition, Microsoft Windows Server® 2008 R2 Standard / Enterprise x64 Edition SP1, Microsoft Windows Server 2008 Standard / Enterprise SP2, Microsoft Windows Server 2008 Standard / Enterprise x64 Edition SP2, Microsoft Windows Server 2003 R2 Standard / Enterprise SP2, Microsoft Windows Server 2003 R2 Standard x64 Edition SP2, Microsoft Windows Server 2003 Standard SP2, Microsoft Windows Server 2003 Standard x64 Edition SP2:

  • процессор Intel Pentium 2 ГГц и выше (или совместимый аналог);
  • 2Гб свободной оперативной памяти (и более).

Требования к программному обеспечению компьютеров

Комплекс «Провин» ориентирован на использование в среде семейства операционных систем (ОС) Microsoft® Windows версий XP SP3, Vista, 7, 8, 10 и серверных платформ Windows Server 2003, 2008, 20012. Учитывая естественные ограничения в полноте и функциональности установленной на компьютере ОС, следует убедиться что система установлена полностью, установлены драйвера всех устройств компьютера, ОС активирована и обновлена до современного уровня, настроен планировщик задач (некоторые фоновые задачи, типа дефрагментации или архивирования, могут вызвать сбои в работе комплекса).

Программно-аппаратный комплекс «Провин» является клиент-серверным приложением. Наиболее активным и «загруженным» в этой связке, выступает, безусловно сервер «Провин». Поэтому, все изложенное в большей части касается именно серверной части комплекса.

Для получения и высокоскоростной обработки и аудио- и видео- потоков от IP-камер программный комплекс «Провин», помимо специализированных библиотек обработки потокового мультимедиа, использует функции графической обработки пакетов API: DirectX и OpenGL, GDI+. Это накладывает определенные ограничения на состав установленного на компьютере ПО. На компьютере с установленным программным комплексом «Провин» крайне нежелательно использовать стороннее или встроенное программное обеспечение, также широко использующее пакеты графической обработки (особенно во время функционирования комплекса). Это может привести к нежелательным сбоям обработки мультимедийных потоков. Кроме того, определенного рода настройки рабочего стола, а именно: использования спецэффектов для окон и меню, подключение различного рода гаджетов и виджетов, также могут привести программным коллизиям.
Вообще следует отметить, что установка комплекса «Провин» на компьютер (сервер) четко определяет роль компьютера в сетевой среде – сервер системы видеонаблюдения для IP устройств. Поэтому, все установленное и/или запущенное ПО, кроме установленного комплекса «Провин», носит вспомогательный характер, помогающий в работе и обслуживании видеосервера.

Во избежание блокировки работы комплекса, следует тщательным образом настроить Брандмауэр Windows, разрешить запуск программ и компонентов комплекса, отключить или минимизировать контроль учетных записей пользователей (UAC), отключить и тщательно настроить Защитник Windows (Windows Defender), снять блокировки с входящих подключений и исходящего трафика, установить разрешение на эхо-запрос.

Те же требования, распространяются и на различного рода службы, запущенные на компьютере. Для стабильного и надежного функционирования комплекса «работает» правило: не следует запускать службы, не имеющие прямого отношения к функционалу компьютера.

Все Windows службы можно условно разделить на две группы:

⊗ службы, которые нельзя или строго не рекомендуется отключать;

· службы, которые можно отключить на компьютере, потому что в большинстве случаев они не востребованы;

Вот пример служб, которые не рекомендуется выключать:

  • Windows Audio - управляет средствами работы со звуком для всех Windows-программ. Если вы отключите эту службу, то все аудиоустройства и звуковые эффекты работать не будут.
  • Windows Driver Foundation - управляет процессами драйверов пользовательского режима.
  • Планировщик классов мультимедиа - разрешает устанавливать приоритетность заданий на основе системных приоритетов задач. Служба предназначена для приложений мультимедиа.
  • Plug and Play - используется для распознания изменений в установленном оборудовании и для упрощенной установки устройств. С появлением технологии Plug and Play (РnР) все устройства, которые ее поддерживают (практически все устройства поддерживают (UРnР), конфигурируются автоматически.
  • Планировщик заданий - ранее планировщик заданий был не особо важной службой, но в начиная с Windows 7 в расписании планировщика очень много важных системных задач, поэтому отключать планировщик крайне нежелательно. Даже отложенная проверка дисков и та выполняется средствами планировщика задач.
  • Удаленный вызов процедур (RPC) - эту службу нельзя отключать, от данной службы зависит очень много других служб, поэтому система запрещает пользователю остановку таких критических служб, как Удаленный вызов процедур.
  • Установщик Windows - не отключайте эту службу, иначе не сможете установить приложения (*.msi).
  • Обнаружение SSDP - обнаруживает сетевые устройства и службы, использующие протокол обнаружения SSDP, такие как устройства UPnP.
  • Рабочая станция - создает и поддерживает клиентские сетевые подключения к удаленным серверам по протоколу SMB. Если данная служба будет остановлена, эти подключения станут недоступными.
  • Сервер - обеспечивает поддержку общий доступ к файлам, принтерам и именованным каналам для данного компьютера через сетевое подключение. Если служба остановлена, такие функции не удастся выполнить.
  • Сетевые подключения - управляет свойствами объектов локальной сети и подключений удаленного доступа.
  • Служба интерфейса сохранения сети - эта служба отправляет сетевые уведомления клиентам сети. Остановка этой службы вызовет отключение от сети.
  • Служба сведений о подключенных сетях - собирает и сохраняет сведения о конфигурации сети и уведомляет программы при изменении этих сведений.
  • Служба списка сетей - определяет сети, к которым подключен компьютер, собирает и хранит данные о свойствах этих сетей и оповещает приложения об изменении этих свойств
  • DHCP клиент - регистрирует и обновляет IP-адреса и DNS-записи для этого компьютера. Если данная служба остановлена, этот компьютер не сможет получать динамические IP-адреса и выполнять обновления DNS.
  • Диспетчер учетных данных - Обеспечивает защищенное хранение и извлечение учетных данных пользователей, приложений и служебных пакетов.
  • Quality Windows Audio Video Experience — передача аудио и видео по сети в режиме реального времени.

Остальные службы, в запуске которых отсутствует необходимость, могут быть переведены в режим запуска «Вручную» и «Отключена» (только если есть уверенность, в не востребованности службы).

Как и для многих серверных платформ, при установке комплекса «Провин» на компьютер, рекомендуется отключать службы управления рабочим столом – «Темы» и «Диспетчер сеансов диспетчера окон рабочего стола». Это безусловно приведет «спартанскому» облику рабочего стола Windows, зато сэкономит большое количество системных ресурсов.

В своей работе, комплекс создает дисковые архивы записей информации от IP устройств. Операции записи-чтения архивной информации производятся в произвольные моменты времени и связаны определенными логическими условиями, в работе с IP устройств из сетевого окружения. Это также накладывает ограничения на состав и функции встроенного и стороннего ПО, активно использующего дисковые операции.

Не рекомендуется использование компьютера, с установленным комплексом «Провин», в качестве сервера баз данных, samba/ ftp/web серверов, сервера локальных и распределенных сетей. Все долговременные дисковые операции (например, дефрагментация дисков), связанные с обслуживанием дисковых носителей – необходимо проводить, только при выгруженных из памяти приложениях комплекса «Провин».